Screeneo U4 | Compact Ultra Short Throw

similar to previous posts, I also received my projector today and I do have issues with blurry corners, out of focus and warped image… @Philips_Support_N is that hardware of software issue? What’s next?

1 Like

I have same problem with connecting my laptops, tried two different, one is completely not recognised, with another one it’s even more interesting: laptop sees that it has second display, but projector still says ‘no input signal’

hey @Philips_Support_N I tried reaching out indiegogo@philipsprojection.com without luck and no answers went to my spambox: it’s weeks I’m told my projectors is in the third batch and it’s being prepared in your warehouse in HongKong. I’m tired of promises and awaiting a product paid 4 months ago.

What is the procedure to stop this never ending preparation and have a full refund?

Hi, I have troubles while using the U4 with my Apple TV 4K

  1. I have to turn off/on the TV 2 times when I turn on the projector, otherwise it’s not recognised.
  2. CEC function stopped working altogether after software update to >=1.6.x. It used to work with the software that came out of the box (I think 1.4.2).

I tried resets, restarts, updates, different HDMI cables etc., nothing is working.

hello Andrei, we will have a check on Monday with our APple TV 4K. We fully tested it 1 week ago and everything was fine. Are you in 4K or Full HD in your Apple TV settings ?

Hi, I’ve tried with both UHD (4K) on/off, also TV settings: 1080p/4K and HDR on/off

Also, changing Audio Output from Internal Speakers to ARC (and vice-versa) seems to trigger the disconnect between the Apple TV and the projector.

For the reference, software version 1.7.0

Buy an ALR screen. Don’t bother researching and buy the 120” motorized from ground up made by WEMAX. I compared all manufacturers that make a virtually identical screen and WEMAX always has the best price (after coupons and all that annoying stuff) and appear to make a superior product for only UST projectors.

Regards
—-
Anthony

Today I recieved my U4 but there’s a problem: It won’t start. I only see a white light in the power button. Is there something wrong?