Screeneo U4 Firmware Update

Hi there,

I have read some of the comments on the Indiegogo thread and some users are experiencing bugs and glitches after installing the firmware update 1.6.3.

Should I hold off installing this update or is it safe to go ahead? My current version is 1.5.7.

Many thanks,

I am having problems trying to update. Did all the instructions but the menu says “File Not Found”.

I did FAT32 format, copy the zip file into the USB and turned on the projector, plugged in the USB, go to settings and do a firmware update. File not found.

Anyone got any other ways to update firmware?

1 Like

I did manage to install the update, but now I regret it as there’s a few bugs. The most noticeable being the fan volume has increased even on night mode.

It took me a while to figure out how to install as I kept getting an error too.

It turned out being because Safari automatically unpacks zip files once downloaded.

If you would rather Safari just download the .zip file and leave if for you to decide what to do:

  1. Open Safari
  2. Click Preferences
  3. Under the General tab, uncheck the option Open “safe” files after downloading

Once I did this and put the file on a USB it installed first time… But as already mentioned, it was probably better without it.

Hello Ryan, we are correcting the bugs for the next version. Concerning the fan noise: we have increased the speed for the Presentation mode as the heat was too high for the optical engine and the metal inside was shapeshifting by few mm and the image was getting unclear. We are still working on it

Ooh shapeshifting sounds cool, shame that it’s not!
Thanks for working to fix this! Has the fan speed on night mode increased as well?

1 Like

Updated to latest version 1.6.4
Fan is running very loud and noisy even in night mode. This didn’t happen with the stock firmware.
Please fix this. It’s noisy in the room.

Oh my! I got the projector, everything buttery smooth and updated to 1.6.4! Damn, I broke it from day 2! The video is so jittery it makes it so annoying ro watch anything! How can I go back to 1.5.7 or something? A new update shouldn’t break the current qualities! If you’re not sure, Philips, release a beta and let us test it.

Again, anyone to help downgrading the firmware? Pretty please?

1 Like

Hello! we just released a new SW for correcting this issue!

Where can we find this please?

Awesome, but, where? lol

After updating to v1.6.6, manual focus (i.e. hold focus button for 2 seconds) no longer works.

Yes, they seem to get rid of that despite it being described in the getting started guide (it was quite unintuitive, though, to be fair). In the newer firmwares, you can manually focus by just clicking on the focus + or - buttons on the remote without clicking the focus button before. And autofocus is one short click of the focus button now. At least that’s how it is with my projector.

On version 1.6.6 now, no change in fan noise tho sigh

I try to update my Os 1.4.3, with 1.6.7 and when the screeneo reboot there is an erreur message.
How can I do ?

1.6.7 is a disaster. My projector is shutting down every few minutes randomly after upgrading to this firmware.

1 Like

I have the same error. Did you find a solution? With me it will do the update, then the Android update to 100%, the device restarts but it says error, restarts and goes back to 1.5.7. Now, by reading the comment above I might just stick with this version ;-).

I had this error, have you tried with another USB key? It worked for me.

My version is upgraded and shows 1.6.7. But there’s stuttering and random shutdowns. Things were fine with 1.6.6 and the only reason I upgrade was hoping to fix the auxiliary audio issue.

Does anyone know how to go back to an older firmware version? Does performing a reset revert the firmware version to what came with the box?

I have raised a support ticket as I wasn’t entirely sure if Philips Projection support actively monitors these threads and will respond to them. I have uploaded a couple of videos of the issue that I am facing as well.