Internal Speaker issues / not working

Hi. Is there something I need to do to get the internal speaker to work. I can get the sound to work no issues via Bluetooth. I’ve tried multiple apps and all the same.

But when I try the same apps with the internal speaker nothing happens.

Do I need to turn it on or something?

It should just work if you turn up the volume.
What does the volume icon on the screen show when you turn the volume up? Might give an idea if the speaker is dead or the volume control is not working

It is about mid way up, with a note symbols beneath it. When in a Bluetooth speaker, the symbol is a note and Bluetooth symbol.

That looks fine. Might be a problem with the hardware, then. Hopefully one of the Philips guys will be able to offer some advice.

Just to narrow things down a bit… do you hear anything if you plug in a headphone into the 3,5mm jack on the back (do so with a low volume at first and only increase the volume gradually).
This will help narrow down which audio pathways are working and which aren’t. You’ve already established that the BT route is working, now we need to know if the internal audio is broken or if the speaker (connection) is broken (or severed / loose)

Wait for tonight’s bug fix update which fixes a volume bug. If problem persists then it could be a faulty speaker needing replacement.

1 Like

I did try the 3.5mm connection and it also doesn’t work.

1 Like

It’s a silly question, but are you sure the bluetooth speaker is disconnected ?
It behaves as if it flows the sound through the bluetooth speaker and therefore doesn’t through the embedded one…

1 Like

Good point, try to manually disconnect all BT speakers from the proper menu, or perhaps even turn off BT before tests.

Bonjours à tous.
Je viens de recevoir mon picopix Max Il est super Mais voilà quand je regarde un film il n’y a pas de son
J’ai voulu le mettre à jours. Il télécharge la nouvelle version mais a 99% il me dit erreur
Donc je ne peux pas le mettre à jours.
Que dois je faire. Merci

Tu peux le mettre à jour hors ligne (update téléchargé sur une clé USB)
Tuto ici :

Pour le son : quelle est ta source de lecture ? directement le PPM ou un lecteur connecté via HDMI ?
Recherche un minimum dans le forum et je suis sur que tu trouveras des réponses à tes questions

1 Like

Si vous voulez des réponses de la communauté, vous devrez écrire en anglais s’il vous plaît

C’est ce que j’ai fait et il s’arrête à 99% Et marque erreur.

Envoyé de mon iPhone

That’s what I did and it stops at 99% and marks error.

Envoyé de mon iPhone

Please try to download the update file again from the procedure above

Hi Folks,

Just recieved today and no sound coming from internal speakers, linked to bluetooth headphones and works fine.

Have tested with bluetooth turned off etc to make sure it wasnt paired to anything for output

really hoping the unit isnt faulty! any ideas?



volume bar is halfway or maxed out, nothing

Did you update the firmware upon receiving it? And do you hear something when you plug in headphones physically in the headphone jack?

Hi ivo

First thing I did was the software update @IvoG

Headphones work fine plugged in 3mm jack wise

Software version 1.1.02

Loaded fine and gui updated… Can’t see it being software related unless there’s a known bug audio wise.

On headphone I can hear the audible clicks when moving around the options, nothing without

Then I’m afraid it’s a faulty speaker (connection). Please send an email to to open a ticket.

I am amazed that the sound in ac3 is not taken into account by the picopix Max while my old model pp4935 takes it. is there a way to read them. thank you

Envoyé de mon iPhone

Just found the 3rd problem with my ppm.
When it is connected to my laptop via HDMI, there is not sound.
I can her a “beep” and then nothing.
Tried to replace the cable, tried to restart the ppm and the laptop, sometimes it is working and sometimes not.
I’m just tired of all those issues, and now i need to wait for a replacement.