PicoPix Max Battery Not Charging

Dear Screeneo Team

I am backer with ID 7898 I have just received my PicoPix Max. It is no possible to charge the battery. There have been some battery power out of the box so I did the software update but this action did not improved the problem. What should I do?

Kind regards
Tryfon Karachalios

Plug in in. AC!

1 Like

Hallo What do you mean, of course I have pluged in AC home current network.

Please follow the the troubleshooting steps posted here: Troubleshooting: Projector won't power on / no picture display / shuts down soon after starting

1 Like

Dear IvoG thank you, I tried to charge a mobile phone with PicoPix Max charger but it is not working either. which means that the charger is defective or the cable is defective, isn;t it?

1 Like

It looks like it then, yes. Please look in this thread for suggestions for alternative chargers to get you going right away, then afterwards send an email to support@screeneo.com to report the defective charger.

IvoG Thank you, it is clear.

1 Like

I’m sorry, I was a bit distracted earlier.
Before contacting support, can you test perhaps if the cable works with another USB-C device?

We need to rule out if it’s the cable or the charger, and I’m guessing (correct me if I’m wrong) you tested both Philips cable and charger together on the other device, which still doesn’t rule either out. If you did test them separately and concluded it’s the charger then mention this to support as well.

Also, not to be demeaning or condescending in any way: did you plug the USB-C cable into the PPM port at the very right, marked with POWER? Some people had not seen the difference and plugged the power cable in the VIDEO port next to it, thinking it wouldn’t matter. In the case of the PPM it does matter though, as one is purely for power only and the other for video only (not even data).

Dear IvoG
I checked both together so I am not 100% sure which one is the faulty one. I suppose the probability is that the charger is defective.
I connected the USB-C to the right port marked power.
It is not easy to check the cable alone because I need to find another charger that has USB-C port. All smart phone chargers I have the cable is one end USB-A the other one USB-C
I will go to a service shop and ask to make the check of the cable. Another solution is to buy a new cable USB-C to USB-C and re-check the charger with the new cable.

1 Like

Just a quick note: if you end up buying a new cable to check the charger with, please make sure it’s rated for high enough power to work with the PPM and charger combination.

1 Like

Yes, thank you for the advise.

1 Like

I have not used the PPM in awhile since Feb, turned it on and downloaded the latest firmware and updates, and left it to charge it overnight, a red LED appeared, so all seemed well.

In the morning, I realised it only charged to around 60%. I tried unplugging and replugging, but the LED did not come on. Turning on the PPM showed normal battery status (not charging).

I have tried the following steps

  1. Changed to Ugreen USB-C to Lightning cable, with original Philips charger, able to charge my iPhone XR
  2. Changed to a working 30W USB C UGreen charger, with original Philips USB C cable, not charging
  3. Changed to another Anker USB C - to USB C cable, with original charger, not charging

I think there is something wrong with the battery or system. Sporadically, while swapping the cables and testing, the Blue LED would come on briefly then disappear.

Kindly advise how I can fix this or get a replacement, thank you.

My order was from Indiegogo

Contribution ID

Just done a search for PicoPix Max manual, and surprisingly there is one now on the Phillips site, not just the quick start guide, had a quick scroll through and came across this,

That was not expected, never noticed a reset hole before and after looking around all 3 USB ports I still can’t find it,
It’s on page 21 of the user manual.

1 Like

It’s on the right side of the projector near the USB-C POWER port. There are 2 reset pins, the one closer to the corner is for service and the one further towards the lens is reset.


I did suspect it might be those 2 holes, they should have made it more clear maybe include a picture,
Anyway thought it might help solve some of these battery non charging issue?

Can you please take a photo with flash, of the USB-C Power port on the projector, from a little above and a little below the port? I suspect the pins inside could be damaged/warped.

Hi, thanks for replying so quick. Let me know if you need clearer pictures, as I currently only have the iPhone XR near me…

Second image…

Hi @daniel.see I tried to zoom in but it’s out of focus. Possible to focus on the usb port? Or better, please check it closely and let us know whether you notice any damaged pins in the USB-C power port. This will help us determine whether to replace your charger+cable, or the entire product. Thanks.

1 Like

is this better? As far as I can tell, the pins are not damaged.

1 Like