PicoPix Max dead on arrival

Just received the unit today, eager to try it, and it seems that the light bulb is dead…

It turns on, the led is shining blue, and the fans go through two stages and continue blowing. No light is emmited, and no picture of course.

I tried plugging in both an HDMI source, and an usb C one, with no luck.

It is responding to the remote power/on of as well, however still no light.

Plugged it in the power socket with the cable/adapter it came and charged it until the let changed from red to blue.

The same happens whether the power is plugged in or running on battery, there is no light coming out.

One more thing I noticed, tilting the unit I can hear the lense motor readjusting (while it’s turned on of course).

Help?

1 Like

Please look at and fill in the checklist in Troubleshooting: Projector won't power on / no picture display / shuts down soon after starting for yourself and post the results here.

Thanks, I already went through the checklist as I explained, but here:

Check Power Adapter and USB cable

  • Are you pressing and holding the power button (on the projector or the remote) for a few seconds? YES
  • Are you using the supplied power adapter and USB-C cable? YES
  • Do you see red/blue flashing LED on plugging in the charger? This means the power adapter you’ve connected is not supported. Please use the supplied power adapter. NO. Led is constant blue when on, red when charging, and constant blue when full.

If you’re using the supplied adapter and cable, continue to the next section.

Check battery charge status

  • Make sure the projector is powered Off. OK
  • Connect the power adapter to the projector. Make sure you plug it into the right side USB-C port (charging port), not the left side (video port)! OK
  • Does the LED turn red? If yes, let it charge for 3 hours until the LED turns blue. Then unplug it, and power it on. Does it work? TURNS ON, NO LIGHT EMMITED.
  • If the LED doesn’t light up at all, check that:
    • the adapter is receiving power from the wall socket.
    • do you have another USB-C device? Can the PicoPix adapter charge that device? If not, the adapter may be Faulty. ALREADY CHARGED.
  • If the LED lights up blue, it means the battery is fully charged. Continue to next section. OK

Check display problems

If your projector can turn on but doesn’t display any picture, check this as you power on the projector:

  • Do you see the white Philips logo startup screen? NO
    • if yes, but there is no picture afterwards, check that all cables (HDMI / USB-C) are unplugged. UNPLUGGED
    • does pressing the home button on the remote or touchpad causes the home screen to appear? NO LIGHT IS EMITTED
    • does pressing the autofocus button on the remote show the focusing screen? NO LIGHT IS EMMITTED
  • Does the projector power off shortly after showing the home screen? It could be a thermal shutdown. check next section. DOESN’T POWER OFF, FANS ARE SPINNING, NO LIGHT IS EMMITED

Thermal shutdown

If you don’t see the Philips startup screen, or the projector powers off soon after starting up, check the following:

  • Do you hear the fan spinning up when you power on the projector? YES
  • Do you have at least 30 cm free space on all sides of the projector to allow free movement of air? YES
  • What is the altitude of your city? (the atmosphere might be thin!) München/Germany
  • What is the room temperature where you’re using the projector? 20C

Here’s a short video of the issue: https://photos.app.goo.gl/REnVNRsRPFKsFSPY8

Well, what do you know, I shook the device before packing it up, and the light turned on… It is currently working, and I’m updating the firmware before anything else.

Doesn’t inspire confidence in the QC or the product really…

4 Likes

This could be a QC failure or a handling failure afterwards (still not good but plausible defect origin).

Get in touch with support@screeneo.com anyways, send them a link to this thread also and wait and see what will come of it. Instead of asking for a replacement right away you might want to wait with getting the replacement (not the reporting, do that right away) until there’s more certain on new deliveries.

I did that, but I already filled out the return Form as they requested.

You are right about holding off returning, I will wait for the stock to pile up first, and see how things are looking in time.

Thanks!

1 Like

Contact them again about that last part then, telling them it started working but that you’re afraid it’s a loose connection which might become undone again through use at a later time.

1 Like

Hi @ViktorM you’re right this was a QC issue (at first). But since we had many more reports of this than expected, I had the production engineer check this. We found that the cable for the light source is a bit too short, adding around 2-3 mm of length solved the issue. But there were still many units produced and ship by the time it was corrected. Since this is a manufacturing defect, these units are being replaced under warranty. If yours works, please keep it, and only send it back if it happens again. Reason being that replacement process is bit of a mess right now. Better to wait for the backlog to be sorted first, in 2 weeks or so it will start running normally. Additionally, if you send it in now, they’ll check and find it working and return it back :neutral_face: I’m checking if they replace the cable anyway.

3 Likes

Thanks @PhilipsEngineering, that is what I intend to do, used it for about 2h yesterday without issues. And Isent and email back to support to hold off with the pickup, hopefully it won’t cause too much trouble…

The issue is documented here, if it happens again I’ll call upon this thread to return under warranty once the stock is normalized.

1 Like

I’m having the exact same issue with my PPM as @ViktorM . I can get it the lamp to turn on sometimes after multiple power cycles and finding the “magic” position to orient the PPM while powering it on. Should I contact support now to get the process started or hold off? I don’t want to have to ship it back and not have a projector that I can get to work occasionally while waiting weeks for a replacement.

1 Like

I must say the picture via Apple TV is amazing when it works! Approximately 144” displayed on my wall with no screen.

1 Like

After you managed to power it on, does the light go out if you move the PPM into the right projection position?

And if once in that position you turn it off and try again next time to put it on (day the next day), does it turn on without issues?

I watched a couple of movies last night (4+ hours) without any issues. I have it mounted on a tripod and turned it off using the remote control. I tried using the remote to turn it on this morning and the lamp won’t start again. If it’s a loose connection, it only seems to affect lamp startup.

Edit: I’m wondering if the loose connection is only needed very briefly at startup. After it illuminates, it then disconnects when I move the projector into the position I need it in. Once I got it started and in position, the projector wasn’t moved/touched again. I don’t know if the power cord being plugged in makes a difference or not. I’ve always had it disconnected when trying to get it to start up, but that might be more of a cord length limitation. When the lamp finally does light up and I connect the power cord, the fourth led lights up as expected.

1 Like

If the cable length is exactly at the limit to make a marginal connection, expansion from heat during use might be enough to help it reach better. Pure guess, but could fit the description of how it tends to be hard to get it to start, but it will often keep going when lit.

1 Like

Hi,
I just received my unit a few days ago after waiting 7 Months.

Well I’m pretty sure it’s broken, when I power up the PPM, I hear all the ventilators but no image is coming out of it, even after 15 min of power on.

I tried to fully charge the battery, remove the adapter, wait 12h, anything and still no image at all.

I’ve contacted support, but no response so far…

Any help would be appreciated.

Thanks.

1 Like

Hi @Arthurs

It seems you encounter this hardware issue :

Read the following posts in the same thread.
You’ll see there’s some kind of tricks which sometimes help to have it working, but if it’s confirmed, you’ll have to send it back to have a new fully working one.

1 Like

Hi jpriley01,
Can you describe the position you used to get it to work ?

I’ll try that…

Thanks.

I have the exact same issue. Tried all the troubleshoot steps and the projection leds won’t come on. I created a support ticket yesterday. Quite a bummer as i’ve waited this since september to arrive. How long will the replacement process take after i have shipped my unit back?

I too am having the same issue after receiving my PPM today. None of the troubleshooting steps helped resolve the issue.