Charging/battery issue

Hi, I just received my PPM but when I put it on charging (using the original usb-c and power adapter) after 5 minutes the red light goes out and the PPM stop charging, no light is displayed…so I have always a low battery level.
If the PPM is on and is on charge the red light is displayed but after few minute again switch to the blue light and after about 20 minutes the PPM shut off.

1 Like

Hello @Armando_Monda,
i see that you are using a multisocket are sure that is plugged in and it works? :wink:
sometimes the best solution is the simpliest! :slight_smile:

I tried with a wall socket always same issue

if you switch on the ppm within the original usb-c and power adapter, did you have the battery charging icon?

Hi @Armando_Monda.
Welcome to this forum.

I don’t recognize the original USB-C cable in your picture.
Is it, or you’re using another one ?

Cable matches the original one in front of me :thinking:

yes @Mario when I switch on the PPM, with the original usb-c and power adapter, the battery icon is in charging but after few minutes it become normal, both led (blue) and battery icon…of course without disconnect any cable…

Hi @LLG it is the original USB-C cable

@PhilipsNono @PhilipsEngineering I made a video about this issue but I can’t upload it here because I am “a new user”…I can’t use the PPM more than 20 minute…let me know what I can do for fix this problem or ask for a replacement unit…

I am “trusted user” now :wink:
1 Like

Looks like defective charger OR defective charging circuit. The first is easy to solve, the second needs return / repair.

So we should really be sure that the power adapter is not the problem. Do you by any chance have another USB-C PD charger?

Also, please follow clearly the diagnosis here and post step by step results:
Troubleshooting: Projector won’t power on / no picture display / shuts down soon after starting

With this I can confirm a hardware fault, and approve a return/replacement. Thanks.

The easiest way to verify the charger is with a multimeter and a usb c cable like the picture (you can buy or do it by yourself ) but of course pay attention!
DELOCK_63947-01

@Mario @PhilipsEngineering Just tried with another USB-C cable and another charger, nothing, same problem. I think is a defective charging circuit…

Ok, seems to be a defective unit. Please email support@screeneo.com for a replacement, and don’t forget to put this thread’s link in it so they approve it faster.

I will do, thank you. I hope to have a new PPM soon :frowning:

Hi @PhilipsEngineering I am quite worried…I sent the form for ask a replacement unit but still no answer from Philips…How long will be the wait?

Please check updates here: For those waiting for replacement units

At the moment we’re still waiting for our logistics company to resume operations.

1 Like

@PhilipsEngineering Whenever I switch on the projector, %charge is around 95-97%, eventhough it has been charged overnight and then it starts charging it it to 100%(after being switched on). Is it normal behaviour?

It’s normal, but try to calibrate your battery once. (discharge fully, leave overnight, recharge fully, keep plugged for 3 hrs after LED turns blue).

The battery percentage display has some tolerance, but since a lot of users asked for it, we’ve added it along with the 3-bar display. The max charge capacity depends on the battery’s age & condition (which again has a little tolerance out of the factory), the temperature and your usage pattern (using Presentation mode too often draws much more power and can prematurely age your battery).

I haven’t been using presentation mode so far. However I wil try with calibration. Also, LED is already blue and when i turn it on the battery % is 97 and then it starts to charge again.