Projector randomly stops drawing external power / Only charges for 5mins at a time

Hi Phillips,

I received my PPM a few days ago and it works like a dream except for when I try and charge it.

When charging the red light comes on then goes off after 3-5mins. I am using the supplied adaptor and usb-c cable.

I have tried different wall power sockets and cables but same issue.

I tried leaving it plugged in all night hoping that it might still be charging but after turning on the projector the battery level still shows as low.

I have read other topics and it seems to be very similar to this 1: Charging/battery issue

Is there any fix for this without having to get a replacement?

I have also been trying to download the latest firmware upgrade hoping that it will fix this issue but it never has enough battery to finish downloading it.

Thanks,
Franz

Hi @Franz_Weishaupl, by ‘goes off’ do you mean it turns blue, or does it turn off completely?

Do you by chance have another USB-C cable or a USB-C power adapter that you can try?

Please do NOT try to update the firmware while the battery isn’t full or the power supply isn’t providing enough power. Even if you manage to download it (or if you do it via the offline method), if the battery dies during the actual upgrade your PPM could be bricked completely I think.

1 Like

I’ve been reading through some of the new posts in this particular categories and that is now 3 PPMs that have charging issues with them. Isn’t this usually picked up in QC or is it plain bad luck ? Just a thought that is all. I haven’t received mine yet and I would hate to have to return it so soon because of a battery fault. ( And spending alot of money too)

1 Like

I’m also worried about this, I hope it’s not structural indeed. It will be important for Screeneo to find out which factory built these units and to see what may be causing these issues. After that it will be important to have these units shipped back and checked as soon as possible so as to find out what the actual physical issue is before many more are made and shipped with a potential defect.
Still, with thousands shipped a sample of 3 or 4 so far that have these issues is not alarming, it could be a problem with the charger, cable, or the PPM itself.

Hi @swdzines you are exactly right, we have noticed this problem coming up more frequently than it should. I am waiting for some troubleshooting info before deciding if it’s faulty hardware (i.e. warranty replacement) or something else (e.g. power plug).

Are you in Australia/New Zealand? @Franz_Weishaupl what about you, are you also in AU/NZ?

About defect rate, the QC tolerance for critical defects is zero, for major defects is 1%. So we’re pretty confident (95% to be precise) that no more than 1% of the units have any problem. In other words we do expect around 10-12 units out of the last 1200 shipment to develop some fault in the next 2 years. If it’s more than that, it’s bad luck. Actually the autofocus problem affected around 1.5% of the units, resulting in us closing the previous factory’s production line entirely now.

I’m based in the UK. I haven’t received my device yet, I’m listed on the next batch to be shipped out soon. Like @IvoG said it’s only been a few devices out of so many that have been affected but it is worrying that it could be down to a faulty cable or plug causing the battery issues. Fingers crossed you get more information soon so you know the next steps!

Do you know roughly out of the the ones that have been returned having this charging / battery issue?

1 Like

Hi Prashant,

So there’s 2 scenarios.

  1. If the projector is turned on and connected to power the light stays red but only until the battery is depleted then the whole projector turns off as well as the light.

  2. I try to charge the projector while its turned off. The red light comes on for 3-5 minutes. Then the light turns off completely.

I have tried with another USB-C cable but same issue. I don’t have another power adapter with the correct power requirements so couldnt try that.

Yes im from Australia :slight_smile:

Hi @Franz_Weishaupl thanks for testing it out. I would like one last piece of data: is the included power adapter able to charge any other USB-C device that you have, e.g. your laptop or phone?

I would suggest you try charging the PPM while it’s turned off with any one adapter that you have that has the most power. What you’re looking for is if the red light still turns off after 3-5 minutes.

Yes the included power adapter is able to charge my phone. I also tested it for 10 minutes with no issue.

I tried charging my PPM (while turned off) with my official Samsung phone fast charger and the PPM light does not turn on at all. I tried plugging directly into a wall outlet and on a powerboard.

Thanks for the extra data point.

@PhilipsEngineering if the charger isn’t able to output 15V for some reason (defective or just not built for that), would the same symptoms occur?

@Franz_Weishaupl thanks for testing. So my conclusion is that the charging circuitry is faulty. Could you please start a return process for warranty replacement by contacting central help desk at https://support.screeneo.com (top right submit a new request). Or use email : support@screeneo.com. You can paste this thread url in your message to avoid describing everything again. Sorry for the inconvenience.

2 Likes

My device has similar behaviour.
It would be charged for a few minutes with red light on. Then the light turns off.
But the device is not fully charged yet.

After a while of unplugging the socket and replug the device, it can be charged (with red light on). And turns off a again a few min later.
Have repeated this process for quite a few times and it is pretty consistent. Any investigation on the source of the reason?

1 Like

Hi @mickeo if you have the same issue as above, I would recommend you to also start a return process. It seems to be a faulty charging circuit.

Mine is doing the same. Only charges for short times while on - then have to pull the cable to get it to start charging again. Otherwise it turns off even though plugged in. Did you find out how to fix it?

i got a new macbook 13" and the charger is compatible with PPM.
So i can confirm it is the problem of the charger rather than the PPM.
@PhilipsEngineering is that a convenient way to replace the charger only?
Thanks

2 Likes

Thanks for the info @mickeo. I might try this as sending back the ppm and waiting on a new one seems a bit overkill if it is just the charger. So you don’t have the issues of the ppm light turning blue even though it is on and not 100%?

1 Like