Can't play downloaded Netflix movies offline

When I power on my PPM without a network connection, the date is set to 2006. This means that trying to play downloaded movies in Netflix gives an error. If I then connect to a network, the time is set correctly and the movies can be played.

Has anyone else encountered and solved this without needing to connect to a network?


As a workaround, you can set the date manually. Go to the Android hidden settings and then find the Date & Time section. There, turn off internet time, and set the date/time manually.

We’ll look into how to solve this in a better way.


Thanks, will try this as soon as I can

You can check my workaround/fix here :wink:

@Philips_Support_P It seems that Automatic option isn’t available in the settings app so perhaps you can add it? Honestly, I’m not sure exactly how my fix worked because when I check it in the android settings, it was set to automatic but I just set it to automatic again anyway and seems to have solved my issue with downloaded Netflix videos.

Not sure I fully understand, can you explain again?

In the settings app, the user can only select from the list of time zones. There’s no option to set it to automatic. If you go to the android menu, it shows that automatic date/time is already set to network provided but it doesn’t seem to be true. I had to select it again before my downloaded netflix videos played offline.

Today I found a problem with the Netflix app, after switching off wifi I tried to play a movie already downloaded just because I was curious to see if I can watch downloaded content when I don’t have access to wifi,
after launching the app it would load straight to my downloaded files which was good and I guess expected since it can not load anything from the site, but after clicking on a movie file I got this error code
‘There is a problem with the video file. (102.2.6)’, so playback was not possible,
Then I tried switching wifi back on and all was fine, and if I switch off wifi after this and go back to it, I was still able to play it,
So after googling the error code the solution given for this code was to set the time and date to automatic, Netflix says 'There is a problem with the video file. (102.2.6)'
So my guess is because the ppm requires an internet connection to update the time Netflix is throwing this code when it doesn’t know the current time,
Now I don’t know if this has been reported before or if anyone is looking in to it, but I do hope there will be a fix for it, because my main use for this is local storage and downloaded files for camping trips etc, when it will be possible

1 Like

I think maybe the Netflix app always tries to check some DRM related stuff to be able to play a file, and yes, it could be as simple as a date/time check online. But having a solution for the timekeeping would indeed be great.


Update: Temporary solution work around found, with wifi turned off I went in to the hidden menu and manually changed the date and time from January 2016 to the current time and date, and bingo it worked, now it’s a little bit of a hassle but it works so I’m happy about that


Ok got it, after further experimentation it seems the Netflix app puts a time stamp on to the download,
It doesn’t need precisely the current time but any time and date after the download was done, as I tried putting in the 1st of May that gave me the same code, but the 2nd of May worked,
So knowing that perhaps the ppm can be reprogrammed to have the default time and date to say 2030 when internet isn’t available to update the time instead of January 2016, that should fool it to work right?
It will save the trouble of manually changing the time .

Better still would be if the time and date settings would be able to draw power from the internal battery to stay updated

1 Like

Yes but I’m also pushing to have the option to have a total shut down of the ppm instead of the current standby mode it’s always in, so I’m not sure then it can keep the time updated hopefully it can, what would have been better is if they put in a watch button battery in only for time keeping, but that’s not possible now.


Every laptop or desktop computer doers that since for ever. And I know there is a small battery dedicated just for that.
@Philips_Support_P Just out of curiosity, why wouldn’t the time and date keep updating if the PPMAX is on standby mode.


Guessing it just wasn’t programmed in to do so, but I don’t see a reason why it can’t be done, because the battery is draining anyway.

1 Like

2030 is just around the corner. Plus perhaps having a date in the future will cause more issues to appear.

1 Like

Have you tried selecting automatic timezone in the hidden menu?
I wasn’t able to confirm that it’s a “fix” but somehow it did when it worked on mine.
Haven’t tried playing offline recently though.


The setting is actually just automatic date and time to use network provided time, not automatic time zone and it’s already selected by default and under it is to set time manually, but manual settings are greyed out when auto is selected , auto has to be disabled 1st then manual settings light up, once time is manually set you can toggle it to auto again, if you don’t time will not update even if there is internet available
The time zone section in the hidden menu is the same as in the main settings, no option for auto, I guess it needs location status in order to work and that is off by default, I haven’t tried switching it on, but my guess is it won’t make a difference as there is no auto time zone option, and even if there is an internet connection will still be needed to determine location.

Haha at least I gave it a 10 year life span, and why do you think I didn’t sign up to no beta testing

1 Like

Hi guys, this is a known issue.

The on-board RTC doesn’t work when the projector is off, for some reason, the ideal solution will be to fix that. Failing that, we will implement approximate save/restore of the last known date and time.

Time zone doesn’t matter here since it’s only used for formatting the display for the user. Everything is done with UTC internally.


Guys, there is no clock in our projector so there is no way to keep the time after reboot. We tried to implement something different with our engineer but failed.
The only way is to make the put the time in manual mode after reset