Vertical colour alignment issue?

I’ve noticed this a few times but ignored it, yesterday I did a tiny bit of investigation.
After turning the ppm on the image looked a bit fuzzy, both on an HDMI source and internal Android:


Note how the green and magenta colours seem to be misaligned vertically.
Power cycling didn’t make any difference.

After a couple of hours of use of the projector, the image was much better:

Has anyone else noticed this?

1 Like

Update: turned the ppm on just now and the image was perfect.

Also, I should add that my ppm is mounted on a bracket on the ceiling so hasn’t been knocked, bashed or moved at all.

Edit 3 hrs later: finished watching for the night, after initially checking image quality via the Android home screen I’ve been watching a film via HDMI. Just returned to the Android home screen by pushing the home button and the image literally fuzzed up in about half a second and now it’s back to the misaligned colours again, per the first two photos I posted above.
I’ve been able to replicate this by switching back from HDMI to built in Android.

I’m not using 4 corner correction, or even the regular keystone correction. Autofocus does not alter the fuzziness.

This isn’t a major problem, but something’s not right.

1 Like

Hi @robincm your first image is definitely not normal and looks misaligned. However the second image looks normal (at that close range). There will usually be some chromatic aberration on sharp text like the one you posted, generally invisible for movies and video content. Your camera’s shutter also exaggerates the colour fringing, unless you take a long-exposure shot.

Note also that it takes about 20 min for the projector to heat up to normal operating temperature, during which the optics expand. So please do run an autofocus once, about 20 min after powering on. It’ll stay stable afterwards.

However what you described about switching between android and HDMI sounds curious. Could you please give us more details? I am interested in looking into it.

1 Like

Good evening @PhilipsPrashant!
You’ll mean the first two images look misaligned and the third looks ok? The third looks fine to my eyes at normal viewing distance.
I think we were typing at the same time, see my previous post update :slight_smile:
I tried to get a video of the image change when switching back from HDMI to Android but I can’t fix the exposure or focus when shooting video on this phone so it’s not very clear in the resulting videos as to what’s happening.

I just noticed I was still on .27 firmware so I’m updating to .29. I’m not sure if that’s going to make any difference but I’ll let you know. Also, I’m running from the power supply not battery, in eco mode.

It’s interesting that yesterday the image was better after I’d been watching some stuff, and today it’s worse.

1 Like

No change on v1.0.29.

Other probably irrelevant info: 20191121 video chip.

On iPhones (which is what I’m familiar with, Android might have something similar) you can press and hold a point you want to focus on, and it will lock the AF and exposure values for the duration of that filming / photo session. You could try that or similar with your phone.

Thanks @PhilipsIvo but that only works temporarily and then the phone decides that it knows better and goes back to auto.

Couldn’t post this last night because the forum seemed to go down for a bit, but I was getting the vertical colour alignment thing from HDMI input too. My ppm HDMI is plugged into an AV receiver so I tried some different inputs. What seemed to be ok, but this needs more testing, is a black screen with a small amount of bright areas, but if the ppm switched to displaying a bright image I’d get the vertical colour fuzziness “ping” in as soon as the image appeared.

This is clearly different to what was going on the other day when I took the photos. Last night I couldn’t get a correctly aligned image using any source unless the image was really dark.

It’s hard to describe, but the distortion was changing really quickly as soon the image was switched. It started off (I think, this was happening within a split second) with the colours not aligned vertically, then seemed to try and pull them into alignment, and then they’d drift back out of alignment again. But that all took less than a second. While that was happening I could hear a faint noise coming from the ppm direction that matched what I was seeing on the screen, kinda like resonance or something. But that might have been the PSU if the current draw was changing - it’s not totally silent.

I would like to reiterate though that this is not currently a serious problem for me, but it’s interesting that it’s happening. My only concern is that it’ll degrade over time but as @PhilipsEngineering mentioned it’s not so noticeable when you have a moving image on the screen. If I use the projector for any static text though then it becomes more obvious because it looks a bit like the focus is out, even though it isn’t.

1 Like

Very usefull information (!)

1 Like

It does that even though you have a Lock? :scream::thinking:

In my experience it stays locked as long as I don’t stop the recording.

1 Like

Yeah different phones, different camera apps.

The colour alignment (and thus fuzziness) changing when the image changes might be a perfectly normal part of the stabilisation process of the optical engine, it quite possibly doesn’t bother moving the mirrors if the screen is constantly black as there’d be no point, so then when something does arrive that needs displaying those mirrors all have to start their oscillations and settle down into them. But on my ppm they seem to not quite get it right, or the oscillation of the mirrors is causing an induced resonance in something, which causes the alignment issue I’m seeing. But that’s all complete guesswork, I have no real clue how the engine works in any detail or how the internal components of the ppm are fitted together.

1 Like

This afternoon the image was good when I first turned the ppm on, but 20 mins later the vertical colour alignment was off.

I tried pulling out the power cable (I usually use the projector running from the supplied PSU) but aside from making the image darker running from battery had no effect.

I’ll try turning the ppm on later and see what happens.

Same thing again: good image straight after power on then got worse.
Image from Chromecast just after power on:


Image from Chromecast after a few hours:

I did try the autofocus but even with manual tweaking this is the best I can get.

If I hadn’t taken photos on the day I started this topic I’d be doubting my memory/sanity about now! But I just checked the times I took those first three photos, and the first two showing the alignment issue were at about 20:30, the third one where the alignment is fine was at 22:13. So that day the image started worse and got better, but the last few tests have seen it do the opposite. Weird.

2 Likes

From my point of view it’s not normal. The 1st image also has chromatic aberration, but it’s normal. The second image isn’t.

It looks sort of the actuator isn’t in sync with the subframes displayed leading to the pixels not showing up where they are supposed to go, but that kind of failure mode would be really odd!

It sounds like you don’t have to restart the PPM for the image to go bad or improve @robincm? Having the issue show up when switching from HDMI to internal source (which will cause the DMD chipset to temporarily lose video sync) would be one thing, but for it to “magically” appear and disappear without losing video input is much harder to explain…

Yes, considering the image size and cost of the ppm I’m more than happy with the picture quality in the image taken at 20:30, but the 21:53 image isn’t ideal. Do you have any thoughts as to why it isn’t consistent? Is this some kind of hardware fault or is it a software thing that could be fixed? I’m happy to try any suggestions/experiments, beta code or whatever if it’ll help.

Also, just wanted to say thanks for your huge amount of work on this project and now forum - much appreciated! And the mods too! :grinning:

1 Like

The HDMI input is connected to a Yamaha AV receiver, but switching inputs on that does briefly cause the screen to black out. Which in retrospect might be what triggers the split second alignment change that I see when the image kicks back in.

Last night I only had the Chromecast input selected throughout but whether that stops/changes the video sync when an app fires up, I’m not sure. But yes, the image went from ok to less than ideal all by itself.

Anything that will cause a refresh rate change or switch between inputs will cause the lose sync and PLL lock (HDCP as well which will cause video to go black until keys have synchronized). A split second of scrambled video followed by correct video is what to expect, not the other way around of course (but the fact that the screen goes garbled/correct all by itself is still odd). Maybe there’s a loss of sync happening despite not changing any video input.

To me it looks like the sub-frames have swapped over, showing the top two in the space for the bottom two and vice versa (or a straight-up delay, difficult to see). Reading the TI documentation it looks like it should scan top left -> top right -> bottom right -> bottom left then repeat, and in your case when it gets messed up it’s difficult to see whether your top left pixel shows up in the bottom left or right corner (and it doesn’t really matter, it’s still not right).

@PhilipsEngineering I guess the actuator is connected to the mainboard through the same ribbon cable as the pixel data? Given that the LE is capable of outputting video that looks correct it can’t really be faulty wiring, can it?

Last night once again the image from Android just after power on was good, but switching to HDMI the Chromecast image was off straight away.

@PhilipsEngineering I hate to ask this, but do you think I should log this as a warranty replacement issue?

As an aside, when I turn the projector on it is switching to HDMI just after Android boots even though my AV receiver is off. I then get the green “no signal” screen. I had tended to be turning the receiver on first but stopped doing that to try and diagnose the alignment issue. I can tell the image quality is ok because I get the ppm input select screen briefly before the no signal screen comes up (I can’t select anything on the input select screen).

I just got the projector today and it seems that I have the same focus issue I tried many different surfaces and retry focus when it completely still . It same all over the screen not just that corner .

Edit this issue seems to be on the latest firmware
I made a factory reset and the focus issue seems to be gone mutch clearer image !
I updated the projector to 29 right out of the box .
Then back to factory

This after factory reset right after reboot I got this 10 times more clear image