Amazon Prime Videos wouldn't play


I am trying to play videos on Amazon Prime (in the US).
But the videos won’t play. Upon clicking the thumbnail, the circle rotates for a minute or so and then I am getting an error message.

P.S. I am able to play videos on youtube, netflix etc.

I tried to go through the forum, but since I did not find the appropriate topic, created a new topic.
If this has already been discussed, please provide me the link.

Also, the error message on the image doesn’t provide much details, instead it is suggesting an amazon app issue. Posting this message as netflix or youtube are working fine.

Hi phania,

I had the same issue and resolved it just now by following the steps as suggested by Juanito. Hope this works for you as well.

  1. Uninstall prime
  2. Clear cache
  3. Use browser on PPM to go to
  4. Search for Amazon Prime Video; download version
  5. Install it
1 Like

I tried it several times and it doesn’t work.
After (re)installing V3.0.264… it works for I while but after turning the Pico off and on again: no picture. Somewhat frustrating.

Yes getting the exact same problem, any help Philips?

Are you also in the US?

Try installing this version instead:

1 Like

Hello All,
Forgot to reply to the posts.

Hello Seb,
I tried following the steps that you mentioned - that is - downloading the version from, but the problem is, the software kept downloading and did not download. I have a very good internet service and the router is very near to the projector.
And thus I gave up. I can put some screenshots if you would like.

Hello IvoG,
I shall try following these steps today and will let you know.
It has been frustrating that Amazon Prime won’t work on the projector.

Thank you

I’m in the UK, the home screen prime app worked fine before the update

And you’re getting the exact error message as well?

Which version is the Prime app, and which FW version are you running?

If I use the home screen app it loads but no thumb nails of the film and will not play, it looks like its trying to load the thumbnails, loading circle over each thumbnail. I tried loading the aptoid version. This version loaded completely but wouldn’t play and gave the exact same warning as above.

Could you give me the actual version numbers please, “the home screen version” or “the Aptoide version” doesn’t narrow it down for me.

I’ll set it up later and get that information.

1 Like

Hi IvoG,

Actually I tried using this version -, and there is clearly some issue with this particular version. When we use the remote to navigate through the thumbnails and press OK, the video doesn’t load. The thumbnail which is selected doesn’t show up that it is selected.

Also, every thumbnail has a small play button at the bottom left. Only if that play button is selected, then the video plays.

Its really hard to get a video played in this particular version.

My PPM is updated to the latest version.

thank you

1 Like

Can you walk me through the process from the home screen through the thumbnail selection to the pressing of play, by filming it and posting a clip? You can send me a WeTransfer link if that’s more convenient.

Hi IvoG,

After I click the Amazon Prime App, I see a bunch of thumbnails.
Let us I want to watch a particular movie, I use my remote to move up and down, and the screen also moves up and down. But when I select a particular title, the title doesn’t get highlighted. And we dont know which movie or title is selected, and when i Click Ok on the remote, the movie doesnt play.

And I dont know what a WeTransfer Link is.

Thank you

The homescreen version is…this the blank thumbnails one
The aptoide version is 5.2.4-googleplay-armv7a…….this loads but neither play


I have the same issue here in Italy, whether geography matters I’m not sure though.
Prime won’t work neither in the two conditions described above nor via screen mirroring from my iPhone app.

Would be great to see it working again soon

Do you guys with a non-working Prime app use a VPN by any chance? Also, what kinf of WiFi network are you using, 2,4GHz or 5GHz?

Hi Ivo

I’m on 5ghz.
I added my credentials to express vpn shortly before prime stopped working actually. However prime does not work regardless whether vpn is on or off…

When I first got the PPM, Amazon Prime Video worked fine. Since the last software update it doesn’t work anymore. It just showed the outlines of the thumbnails and the title of the movie but when I clicked on it, nothing happened. To try to fix it, I uninstalled the app and reinstalled it from Aptoide TV. Now when I click on the app, absolutely nothing happens and it just goes back to the home screen.